You are not logged in.

Tuesday, September 2nd 2014, 6:40pm

The Avira Forum will be moved to the new platform Avira Answers soon. We'll make the transition of existing user profiles and threads as smooth as possible.
New visitors are able to log in on Avira Answers with the existing Avira account directly or sign up with a new account.

  • "elainew" started this thread

Date of registration:
Jul 20th 2009

  • Send private message

1

Tuesday, July 21st 2009, 12:00am

Update error: UpdateLib delivers error 537

I have been unable to update my Premium Ed. (Ver. 9) for several weeks now. When I try to update I quickly get the following message in the status box:
'An error occured during file download'

and when I go into the report it starts out as follows:

UPD] [INFO] Checking whether newer files are available.
[UPD] [INFO] Select update server 'http://premium.avira-update.com/update'.
[UPD] [INFO] Downloading of 'http://premium.avira-update.com/update/idx/master.idx' to 'C:\Documents and Settings\All Users\Application Data\Avira\AntiVir Desktop\TEMP\UPDATE\idx\master.idx'.
[UPDLIB] [ERROR] Download manager: An error occurred inside the WinINet library.
...
Ending with the following:
UPD] [ERROR] Generation of update structure failed. UpdateLib delivers error 537.

I can't find any reference to error 537 anywhere else. Can anyone help?

Date of registration:
Jan 5th 2009

Operating System:
XP

  • Send private message

2

Tuesday, July 21st 2009, 9:27am

Hi,

Please try to make a manual update
Thanks for choosing Avira
Alexandru Manea
Avira Operations GmbH & Co. KG

  • "elainew" started this thread

Date of registration:
Jul 20th 2009

  • Send private message

3

Tuesday, July 21st 2009, 1:40pm

Thanks for that- the manual update worked so everything is up to date for now.
It hasn't resolved the problem with the automatic update though. Will I have to update manually from now on or is there something I can try to fix the problem?

Date of registration:
May 22nd 2006

Operating System:
XP

  • Send private message

4

Tuesday, July 21st 2009, 1:58pm

Hi,
Does this command work?
"C:\Program Files\Avira\AntiVir Desktop\update.exe" /DM="0" "/NOMESSAGEBOX /receivetimeout=120"
Nicolae Moldoveanu
Avira Operations GmbH & Co. KG

gnagflow

Community member

Date of registration:
Mar 3rd 2006

Version:
Avira Internet Security Suite

Operating System:
WIN7 U SP1, WIN 8.1 64-bit

  • Send private message

5

Tuesday, July 21st 2009, 5:16pm

is a firewall in use?
In seinem Lachen liegt der Schl├╝ssel,
mit dem wir den ganzen Menschen entschl├╝sseln

- Thomas Carlyle - 1795-1881 brit. Schriftsteller

  • "elainew" started this thread

Date of registration:
Jul 20th 2009

  • Send private message

6

Wednesday, July 22nd 2009, 12:21pm

Thanks for the help- I'll reply to the last two posts together if that's OK.

Hi- yes there is a firewall in use, it is configured to allow all access from Avira but I disabled it just in case.

The command does work and so does my automatic update now! It updated with the command and I tried it direct from the overview- no problems.

Whatever it was, the problem appears to be solved/disappeared so thanks all of you for your help!

Date of registration:
Jan 5th 2009

Operating System:
XP

  • Send private message

7

Wednesday, July 22nd 2009, 12:24pm

You are welcome. Thank you for your feedback.
Thanks for choosing Avira
Alexandru Manea
Avira Operations GmbH & Co. KG