You are not logged in.

Monday, July 28th 2014, 4:21pm

The Avira Forum will be moved to the new platform Avira Answers soon. We'll make the transition of existing user profiles and threads as smooth as possible.
New visitors are able to log in on Avira Answers with the existing Avira account directly or sign up with a new account.

  • "fuugi" started this thread

Date of registration:
Apr 15th 2008

  • Send private message

1

Tuesday, April 15th 2008, 2:30pm

Since updating, event log cannot be initialised

Hi, since updating today to version 8 and restarting the computer afterwards, when i opened the Control Centre, i received the message:

Open event database failed: No write access to database.

In addition, when i go the the events log, it is empty, and when i try to scan anything, i receive the message that "The event log database could not be initialized".

If anyone can shed some light on this problem, i would be very grateful!

[Edit]: also when i go to
C:\Documents and Settings\All Users\Application Data\AntiVir PersonalEdition Classic\EVENTS

this folder is completely empty. not sure if that is the cause of the problem though.

This post has been edited 1 times, last edit by "fuugi" (Apr 16th 2008, 6:52am)


Date of registration:
Oct 19th 2006

  • Send private message

2

Thursday, April 17th 2008, 12:07am

[SOLVED] Since updating, event log cannot be initialised

Open event database failed: No write access to database.

I had the same problem too! But i found a way to fix it.

In my case, I have disabled Window's simple file sharing, that means, that I can set permissions for each and every file and folder on my pc so that it satisfies my needs.

I have ran with problems related to this before, new installations seem not to work correctly due to the fact that these do not set the correct permissions to their data folders... So first, let me tell you how to check if you have disabled simple file sharing... and if you did... the steps I followed to fix my problem but help you as well.

(Sorry if the names don't match, my Windows is on spanish and I'm trying my best to guess the english version :D)
You can check if you have it disabled by right clicking on any file or folder, going to "properties" and if a "Security" tab exists, then you have simple file sharing disabled. You can also check this configuration by clicking on the "Tools > Folder options" menu of any explorer instance. On the new window, go to the "View" tab, and the last of the items on the advanced configuration list should be the "Use simple file sharing (recommended)" item... disabled.

So, if you have simple file sharing disabled, this MIGHT solve your problem.
Go to
C:\Documents and Settings\All Users\Application Data

Right click on
AntiVir PersonalEdition Classic
and go to Properties.

On the properties window, go to the "Security" tab. Depending on the list of users that appear, two things can happen:

A)
If on the list "Everyone" (or "all"... not sure) appears, make sure that that user group has all the permissions.
You can make sure all the permissions are set by clicking on the user and checking if the permisions below are all set, if they're not, check them all, click on "Accept" and give it another try.

B)
The group "Everyone" it doesn't appear, we'll have to add it...

Click on "Add.."
Click on "Advanced..."
Click on "Search now" (should be to the right, right in the middle of "Columns" and "Stop")
From the list that appears below, select "Everyone" and click on "Accept"
Click on "accept"
For the new "Everyone" user that appears on the list, mark all permissions.
Click on "accept" to apply changes...

Give it a try!


Avira staff, why has this happened? (By the way, congrats for the new version, the AV is looking great! And it's good to know it's faster too!)

This post has been edited 2 times, last edit by "Fred_Pyo" (Apr 17th 2008, 12:17am)